Получение текста web-страницы используя HTTPСоединение - 1С-ИнтеГрация

Получение текста web-страницы используя HTTPСоединение



  Код 1C v 8.х
 //На прямую
                         Сервер = "w1c.ru";                          
                         Соединение = Новый HTTPСоединение(Сервер);                   
                         Заголовки = Новый Соответствие;
                         Заголовки.Вставить("host", Сервер);                 
                         Запрос = Новый HTTPЗапрос("/work.html", Заголовки);
                         Ответ =Соединение.Получить(Запрос);
                         Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
                                 ТекстСтраницы= Ответ.ПолучитьТелоКакСтроку();
                                 //Выведем тест полученной страницы
                                 Сообщить(ТекстСтраницы);
                         КонецЕсли;    



Код 1C v 8.х

       // ЧЕРЕЗ ФАЙЛ
                         Сервер = "w1c.ru";
                         НТТР = Новый HTTPСоединение(Сервер);
                         врФайл = КаталогВременныхФайлов()+"pr_"+Формат(ТекущаяДата(), "ДФ=ddMMyyhhmmss")+".txt";
                         Ответ = НТТР.Получить("/work.html", врФайл);
                         Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
                                 //Выведем тест полученной страницы
                                 ВходящийФайл = Новый Файл(врФайл);
                                 //Сообщить(ВходящийФайл.Размер());
                                 Текст = Новый ТекстовыйДокумент;
                                 Текст.Прочитать(врФайл,КодировкаТекста.UTF8);
                                 Для н=1 По Текст.КоличествоСтрок()Цикл
                                          стр=Текст.ПолучитьСтроку(н);
                                          //Выводим текст страницы построчно
                                          Сообщить(стр);
                                 КонецЦикла;
                         КонецЕсли;       
   

 

 



Назад в раздел