v8: Релиз УТ 11. Разбор полетов с печатью документов и прикрепление новых форм. - 1С-ИнтеГрация

v8: Релиз УТ 11. Разбор полетов с печатью документов и прикрепление новых форм.




Создание нового отчета или обработки 

Примеры дополнительных обработок (отчетов) имеются в демонстрационной конфигурации. В общем виде, последовательность создания дополнительной обработки (отчета) следующая: 

1. Создать внешнюю обработку (отчет) 

2. Регистрация дополнительной обработки в информационной базе происходит на основании сведений, которые поставляет сама обработка. Эти сведения должны возвращаться в виде структуры в функции СведенияОВнешнейОбработке (приведено со служебными функциями): 
Копировать в буфер обмена 

Функция СведенияОВнешнейОбработке() Экспорт
  ПараметрыРегистрацииставить("Вид", …);
  ПараметрыРегистрацииставить("Назначение", …);
  ПараметрыРегистрацииставить("Наименование", …);
  ПараметрыРегистрацииставить("Версия", …);
  ПараметрыРегистрацииставить("БезопасныйРежим", …);
  ПараметрыРегистрацииставить("Информация", …);
 
  ТаблицаКоманд = ПолучитьТаблицу_Команд();
 
  ДобавитьКоманду(ТаблицаКоманд,
          <Имя команды>,
          <Идентификатор команды>,
          <Способ вызова команды>,
          <Показывать оповещение>,
          <Модификатор>);
 
  ПараметрыРегистрацииставить("Команды", ТаблицаКоманд);
 
  Возврат ПараметрыРегистрации;
 
КонецФункции
 
Функция ПолучитьТаблицу_Команд()
 
  Команды = Новый ТаблицаЗначений;
  Командыолонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Командыолонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Командыолонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Командыолонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Командыолонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
 
  Возврат Команды;
 
КонецФункции
 
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
 
  НоваяКоманда = ТаблицаКомандобавить();
  НоваяКомандаредставление = Представление;
  НоваяКомандадентификатор = Идентификатор;
  НоваяКомандаспользование = Использование;
  НоваяКомандаоказыватьОповещение = ПоказыватьОповещение;
  НоваяКомандаодификатор = Модификатор;
 
КонецПроцедуры

где поля структуры имеют следующее назначение: 


Ключ 
    
 
Содержание 
 
Вид 
    

строка, вид обработки, один из возможных: "ДополнительнаяОбработка", "ДополнительныйОтчет", "ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов" 


Назначение 
    

Массив строк имен объектов метаданных в формате: <ИмяКлассаОбъектаМетаданного>.[ * | <ИмяОбъектаМетаданных>]. Например, "ДокументчетЗаказ" или "Справочник.*". Прим. параметр имеет смысл только для назначаемых обработок, для глобальных может не задаваться. 


Наименование 
    

Наименование обработки, которым будет заполнено наименование элемента справочника по умолчанию - краткая строка для идентификации обработки администратором 


Версия 
    

Версия обработки в формате “<старший номер>.<младший номер>” используется при загрузке обработок в информационную базу. Например “. 


БезопасныйРежим 
    

Принимает значение Истина или Ложь, в зависимости от того, требуется ли устанавливать или отключать безопасный режим исполнения обработок. Если истина, обработка будет запущена в безопасном режиме. Более подбробно о безопасном режиме в справке к платформе 1Средприятие. 


Информация 
    

Краткая информация по обработке, описание обработки. 


Команды 
    

Команды, поставляемые обработкой. Таблица значений с колонками: 

Представление – представление команды в пользовательском интерфейсе; 

Идентификатор – идентификатор команды; любая строка, уникальная в пределах данной обработки (отчета). В случае с обработками печатных форм на основе макета табличного документа передается список макетов, на основе которых нужно получить печатную форму (см. описание параметра ИменаМакетов процедуры УправлениеПечатьюКлиентыполнитьКомандуПечати в разделе Печать). 

Использование – варианты запуска обработки: 

? "ОткрытиеФормы" – открыть форму обработки; 


? "ВызовКлиентскогоМетода" – вызвать клиентскую экспортную процедуру из модуля формы обработки; 

? "ВызовСерверногоМетода" – вызвать серверную экспортную процедуру из модуля объекта обработки. 

ПоказыватьОповещение – если Истина, требуется показать оповещение при начале и при завершении работы обработки. Имеет смысл только при запуске обработки без открытия формы. 

Модификатор – дополнительный модификатор команды. Используется для дополнительных обработок печатных форм на основе табличных макетов, для таких команд должен содержать строку ПечатьMXL (см. пример в демонстрационной конфигурации).

Источник



Назад в раздел