v8.x: Как подключиться (присоединится) к базе 1С 8 через СОМ - 1С-ИнтеГрация

v8.x: Как подключиться (присоединится) к базе 1С 8 через СОМ



 Код 1C v 8.х

 //Пример 1

v8 = CreateObject("V8.COMConnector");

//Строку подключения можно получить так:

Если ФайловаяБазаДанных Тогда

        СтрокаПодключения = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";

Иначе

        СтрокаПодключения =  "srvr='" + Сервер + "'; ref='" + БазаДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";

КонецЕсли;

Попытка

        //Соединение = V8.Connect("Usr=""admin"";Pwd="""";File=""\\srvr\1C\V8\UPP""");

         Соединение = V8.Connect(СтрокаПодключения);

Исключение

        Сообщить(ОписаниеОшибки());

КонецПопытки;

 

 

//Пример 2

Функция ОткрытьСоединение(ОписаниеОшибки) Экспорт

     СтрокаПодключения = СформироватьСтрокуПодключения();

        Connector = Новый COMОбъект("V8.ComConnector");

   

    Попытка

        DataSource = Connector.Connect(СтрокаПодключения);

    Исключение

        ОписаниеОшибки = ОписаниеОшибки();

    КонецПопытки;

   

    Если DataSource = Неопределено И ПустаяСтрока(ОписаниеОшибки) Тогда

        ОписаниеОшибки = "Неизвестная ошибка подключения к 1Средприятие 8.0";

    КонецЕсли;

   

    Если Не ПустаяСтрока(ОписаниеОшибки) Тогда

        DataSource = Неопределено;

        Connector  = Неопределено;

    КонецЕсли;

   

    Возврат DataSource;   

КонецФункции

 

Функция СформироватьСтрокуПодключения()

   

    СтрокаПодключения = "";

    Если ЭтоСервер Тогда

        СтрокаПодключения = СтрокаПодключения + "Srvr=" + Сервер + ";Ref=" + Имя + ";";

    Иначе

        СтрокаПодключения = СтрокаПодключения + "File=""" + Сервер + """;";

    КонецЕсли;

    СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пользователь), "", "Usr="""  + Пользователь + """;");

    СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пароль), "", "Pwd="""  + Пароль + """;");

   

    Возврат СтрокаПодключения;   

КонецФункции

  

 



Назад в раздел